0
0

Hi

I’m new to FMOD. I have a problem. I’m using Eclipse with MinGW Compiler. Now which library do i need to include?

For MinGW it says I should use libfmodex.a but that is not possible in Windows is it? If I try it it says it cant find "libfmodex".

So I tried the other .lib files. No errors come up but if I use only one function of FMod no .exe file will be created.

What do I wrong? Can you help me with this please?

  • You must to post comments
0
0

[quote="Eistoeter":2v8063gp]Hi

I’m new to FMOD. I have a problem. I’m using Eclipse with MinGW Compiler. Now which library do i need to include?

For MinGW it says I should use libfmodex.a but that is not possible in Windows is it? If I try it it says it cant find "libfmodex".

So I tried the other .lib files. No errors come up but if I use only one function of FMod no .exe file will be created.

What do I wrong? Can you help me with this please?[/quote:2v8063gp]

Search for dev-c++ (which uses MinGW) wich has the same difficulties

http://52.88.2.202/forum/viewtopic.php … light=devc

As you will see, you will be limited to the standard C interface but It works great in any case

As for not finding the lib, I had problems with Vista and Dev-cpp… the problem is MinGW related… It has trouble locating files such as libraries and even the resource compiler in my case… Worst when compiling a DLL.

The solution for me was to move the project under a folder in the dev-c++ instalation directory and move the FMOD includes and lib folders in a sub folder in my project folder.

dev-c++ folder\
dev-c++ folder\myproject\ (my project goes here)
dev-c++ folder\myproject\inc\ (fmod includes go here, add the folder to your include directories in your options)
dev-c++ folder\myproject\lib\ (fmod libs go here, add the folder to your library directories in your options)

Add the .a lib to your linker…

  • You must to post comments
0
0

Thanks a lot for your help.

I use the C interface now it works great.

The problem with the library was that I said my linker to link libfmodex. But I needed to say only fmodex without "lib"

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.