0
0

We are finding the wet reverb mix seems to be sent before it’s got any DSP effects on it (ie, FMOD low pass simple). We are trying to do a gunfight and at distance remove the high freq. but find that as soon as we add a reverb (using the reverb tab) all the top end comes back.

Is there a nice diagram of the connections somewhere I could view?

Thanks

  • You must to post comments
0
0

I think that should be possible with later versions of FMOD designer by using the integrated "profiler".

  • You must to post comments
0
0

I took a shot of the DSP graph, and it does indeed seem it gets takes the reverb off before any DSP effects have been processed.

Is that how it’s going to be, or a small bug somewhere?

[img:1p5vm8w5]http://i175.photobucket.com/albums/w129/a1psx/ourdsp.jpg[/img:1p5vm8w5]

  • You must to post comments
0
0

Its not a bug, its to stop the wet path being affected by things like occlusion lowpass.

When obstructing a sound (not totally occluding it with something like a wall. Think of a stone pillar between you and the sound) the reverb can’t be affected by the object obstructing it. The sound have the possiblity of being totally silent, but with the reverb still audible (because it is bouncing around the room and into your ears).

In this case, if there was a pillar in front of you and reverb was connected after the lowpass, all reverb for that sound would dissapear as well which is not desired.

It depends on where it should connect if you consider the effect ‘part of the sound’ or something that is a byproduct of outside influences.
We can look at adding an init flag maybe to change the way it connects but I would prefer at the moment if users connected their own reverb if they are doing things differently like that.

  • You must to post comments
0
0

Ah, I thought you would add the occlusion lowpass dsp once you’d take the wet.

I’ll look into fixing it up our end like you say.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.