0
0

I’m using custom file callbacks with createstream to play back mp3 files. This is all working well, except that when fmod starts playback it reads a little bit at the beginning of the file, then seeks to the end and reads a bit, then seeks back to the beginning and begins playing the stream.

While this works fine, my files are located across a network, so this extra seek/read at the end of the file doubles the number of server roundtrips required to start playback. I’m almost positive that mp3 can be streamed without requiring that the end of the file be reachable at any point, so it seems that this seek/read pair are not needed, at least not for my application.

Is there a way to disable this behavior?

  • You must to post comments
0
0

yes use FMOD_IGNORETAGS. mp3 has tags that are stored at the end of the file.

  • You must to post comments
0
0

Works great, thanks.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.