0
0

I have hundreds of players/bots moving around in 3D and making various sounds.

Rarely, I will have many in the same area at the same time, making the same sound.

If is deafening, due to the additive blend.

What is the proper solution to this problem?

Tom
http://www.armyofearth.com

  • You must to post comments
0
0

have a look into soundgroups, and the max playbacks behaviour.

  • You must to post comments
0
0

You mean setMaxAudible/setMaxAudibleBehavior? That’s what I have been using.

I’ll experiment a bit more with it to see if I can get rid of the discontinuities I am hearing.

  • You must to post comments
0
0

I re-examined the code and figured that my problem might be due to priority stealing. However, bumping up the priority of these sounds made no difference.

What I have is a sound for which I have setMaxAudible(1) and setMaxAudibleBehavior(FMOD_SOUNDGROUP_BEHAVIOR_STEALLOWEST). I am now also setting priority to 0 on the play.

I am hearing this sound cut out or fail to play, even when it is for the hero, i.e. the closest player that can emit the sound.

I didn’t want to setMaxAudible higher because multiple coincident plays would be too loud.

What’s wrong?

Cheers,

Tom
http://www.armyofearth.com

  • You must to post comments
0
0

[quote="fundictive":3d8zkwr8]bumping up the priority of these sounds made no difference[/quote:3d8zkwr8]

Bumping [b:3d8zkwr8]up[/b:3d8zkwr8] might be the problem are you increasing or decreasing the priority value?

[quote="fmodex.chm":3d8zkwr8]priority for the channel. 0 to 256 inclusive. 0 = most important. 256 = least important. Default = 128[/quote:3d8zkwr8]

Hope this is helpful

  • You must to post comments
0
0

No, that is not it. I bumped up the priority to 0.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.