0
0

I’ve read the docs how to setup the speakermode to that speakermode set in Windows, like this:

[code:39c3jkm4]
//get the speaker mode from the control panel in windows and set it to this in FMOD
FMOD_SPEAKERMODE speakermode;
m_result = m_system->getDriverCaps(0,0,0,0,&speakermode); // Get speaker mode for default driver.
ERRCHECK(m_result);
m_result = m_system->setSpeakerMode(speakermode);
ERRCHECK(m_result);

m_result = m_system->init(32, FMOD_INIT_NORMAL, 0);
ERRCHECK(m_result);

[/code:39c3jkm4]

However, even if the user sets speakermode in control panel in Windows so that stereo sound should play through all 5(1) speakers, fmod only plays the sound through left and right.

Have I misunderstood something?

  • You must to post comments
0
0

I mean I want to fill a stereo sound into all 5.1 speakers.

A user of mine with a surround card use the progam bundled with it to select 6 channels and also enabled [speaker fill] in window’s sound manager. All progams he test with, Winamp, Foobar, Goldwave etc. plays the sounds through all 5.1 speakers. But mine application only 2.

And this worked with an earlier FMOD version, a few months ago.

  • You must to post comments
0
0

have you tried explicitly using the FMOD_SPEAKERMODE_5POINT1 flag instead of getDriverCaps? Try the flag and if it doesnt work there may be other issues which need resloved (especially if it works with other audio software).

  • You must to post comments
0
0

No, I haven’t tried that but I don’t think that’s such a good idea.

From the docs:

[quote:3ncfyrv8]
Sound will not behave correctly unless your control panel has set the speaker mode to the correct setup.
For example if FMOD_SPEAKERMODE_7POINT1 is set on a speaker system that has been set to ‘stereo’ in the windows control panel, sounds can dissapear and come out of the wrong speaker.
[/quote:3ncfyrv8]

  • You must to post comments
0
0

I wasnt suggesting it as a permanant solution, just a test. just set your speaker mode in windows to 5.1 then use the flag in FMOD, if it doesnt work, then there maybe something else wrong.

  • You must to post comments
0
0

Had a look at the examples, and I guess I should use

[code:2dn01e50]result = channel->setSpeakerMix(1, 1, 1, 1, 1, 1, 1, 1);[/code:2dn01e50]

to enable all the speakers…

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.