0
0

i read the faq and the other linux compilation topic but it didnt help me.

im used to doing configure make make install
and this is a little different (4 me)..

anyways, im using RH7.0 (but with new 2.4.5 kernel)

the version of gcc RH7.0 has is 2.96

i downloaded and extracted the api.
and im trying to compile samples/simplest
(cos its simple i guess :smile:

the Makefile in /simplest says..

flags=-DPLATFORM_LINUX -O3 -I../../api/inc -L../../api -lfmod-3.3

all: Main.cpp
g++ ${flags} Main.cpp -o Simplest

clean:

rm -f Simplest

and README.TXT says..


Linux users, just link with libfmod-V-V.so (gcc file.c -lfmod-3.33)

and this is what iv been typing at the command prompt at /samples/simplest

g++ -DPLATFORM_LINUX -O3 -I../../api/inc -L../../api -libfmod-3.33.so Main.cpp -o Simplest

and i get the following error message.

/usr/bin/ld: cannot find -libfmod-3.33.so

collect2: ld returned 1 exit status

i tried running ldconfig but i still get the same error.

im probably not using the flags correctly im not sure, im confused.. i guess im still a newbie, me suck :smile:

I flag points to the include dir
L flag points to where the libfmod-3.33.so library is..

so im confused…especually with what README.TXT says.

i hope someone can help me.

thanks.

PS. i found out about fmod on a local forum. forums.overclockers.com.au someone was saying fmod could be used to run an mp3box with only a 486 and 8meg of ram (windows version) so i had to see what wonders the linux version will do.

  • You must to post comments
0
0

you have to copy the library (*.so) into
/usr/lib and then execute (as root) the program ldconfig, so the system knows about the new library.
It should then run fine.

  • You must to post comments
0
0

thanks. ill give that a try when i get home from work.

am i using the right commands/paramaters at the command line?

<font size=-1>[ This Message was edited by: theone333 on 2001-07-09 05:25 ]</font>

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.