0
0

Hi Guys,

I have this code to load GCADPCM files…

[code:1gn3wbgr]
createSound(filePath.AsChar(), FMOD_HARDWARE, NULL, &pSoundMain);
[/code:1gn3wbgr]

everything loads and plays fine. I want to save some memory and keep the sounds compressed so I did this

[code:1gn3wbgr]
createSound(filePath.AsChar(), FMOD_HARDWARE | FMOD_CREATECOMPRESSEDSAMPLE, NULL, &pSoundMain);
[/code:1gn3wbgr]

and now I get FMOD_ERR_FORMAT returned….

What am I missing? I can send you the .dsp file I am using if that would help…

Thanks –

Alex

  • You must to post comments
0
0

Oh, my version:

FMOD Ex Version ‘0x41307’

  • You must to post comments
0
0

Hi,

If you create a GCADPCM sample, it is already decoded in realtime by the hardware.

This FMOD_CREATECOMPRESSEDSAMPLE flag only applies to software mixing, and for MP2, MP3, IMAADPCM or XMA formats. This information is in the FMOD_MODE section of the FMOD docs.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.