0
0

fmod/designer: 4.19.04

  • init the eventsystem with:
    FMOD_EVENT_INIT_NORMAL | FMOD_LOWMEM | FMOD_INIT_SOFTWARE_OCCLUSION
    *bank is built with Force software set to YES
    *event has 3D mode (distance 100/10000), the wave is a simple white noise with all frequencies covered

I first build the geometry then save it and at runtime I load it with system->loadGeometry. Occlusion polys have direct & reverb occlusion set to 0.85.

When occlusion poly gets between the listener and the sound source, only the event’s volume get’s reduced. Shouldn’t a lowpass filter be applied instead?

I’m also rendering the occlusion polys with runtime information from Geometry interface (getNumPolygons, getPosition, getRotation, getPolygonVertex, …) and polys are at correct position, single/double sided polys also seem to work ok.

What am I missing?

  • You must to post comments
0
0

On what basis are you saying that only the volume is being reduced? Is this via just listening to it?

  • You must to post comments
0
0

no, i also use an visual audio meter and when playing white noise, the drop happens on all frequencies with the same value.

  • You must to post comments
0
0

well 2 things i’d do first.
Make sure the lowpass filters are connected. Run the fmod profiler on your app and look at the dsp tree and see if all the connections contain lowpass filters.
check against fmod’s geometry example. I also have an event based one here that isnt public and it definitely uses lowpass filtering.
There’s not really much to it, you just use the fmod_init_software_occlusion flag and that’s about it.

  • You must to post comments
0
0

found it
the profiler showed no lowpass filter connected. as it shows up, i was stuffing the FMOD_INIT_SOFTWARE_OCCLUSION flag into the ‘eventflags’ parameter of the EventSystem::init function… oh well 😳

works now, thx

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.