0
0

Hey,

When I’m trying to create sound with unicode path or filename, I get: ERR_FILE_NOTFOUND

[code:3gdcs3s2]
string path = "Path to mp3 with unicode characters in name";
result = system.createSound(@path, (FMOD.MODE.UNICODE | FMOD.MODE.SOFTWARE | FMOD.MODE._2D), ref sound);
ERRCHECK(result);
[/code:3gdcs3s2]

I’ve tried with both FMOD.MODE.DEFAULT and FMOD.MODE.UNICODE, also tried setting these to unicode, auto or ansi in fmod.cs but it didn’t work.

[code:3gdcs3s2]
[DllImport (VERSION.dll, CharSet = CharSet.Unicode)]
private static extern RESULT FMOD_System_CreateSound (IntPtr system, string name_or_data, MODE mode, ref CREATESOUNDEXINFO exinfo, ref IntPtr sound);
[DllImport (VERSION.dll, CharSet = CharSet.Unicode)]
private static extern RESULT FMOD_System_CreateStream (IntPtr system, string name_or_data, MODE mode, ref CREATESOUNDEXINFO exinfo, ref IntPtr sound);
[/code:3gdcs3s2]

I’ve also tried with different culture settings and string encodings (ansi, ascii, utf32, utf8, utf7 and "unicode").

How can I load a file with non-ascii characters with FMOD EX 4.19.07?

Platform: Windows XP Pro x86_64 with SP2.

Thanks

  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.