0
0

Hi,

I have assigned certain sound definitions the ‘shuffle’ play mode. According to the manual…

"Shuffle : Waveforms are played back in a quasi random order, with an added restriction that no waveform is repeated until all waveforms have been played."

However, it doesn’t seem to work as described. I certainly hear repeats long before every waveform in the sound definition have been heard.

Is this a bug?

Thanks,

FP

  • You must to post comments
0
0

[quote="Flying Poo":134urltu]
However, it doesn’t seem to work as described. I certainly hear repeats long before every waveform in the sound definition have been heard.

Is this a bug?
[/quote:134urltu]

How are you using the event? Are you triggering multiple instances of the event? If so, you might get better results using the ‘Shuffle Global’ play mode.

Either way, we will try to reproduce the problem here.

Is the bug occurring in Designer, Event Player and/or your game?

cheers,
Templar

  • You must to post comments
0
0

Hi Templar,

Sorry, looks like the problem was a wrong assumption on my part. I was experiencing this issue when previewing the sounds from the top portion of the sound definition window (the play button just above the section where I actually assign the play mode). In most cases this play button does seem to mirror the play mode selected. For example, if I select ‘random’ and then click the play button repeatedly, it seems to work fine. However, both ‘shuffle’ and ‘sequential’ produce unreliable results. Setting it to ‘sequential’ and then clicking the play button repeatedly seems to only play the first waveform over and over (as opposed to playing through the list in sequence as would be expected). ‘Shuffle’ results in what sounds just like ‘random’, with the occasional repeat – which is what prompted my original posting.

Within the event player the results do appear to work correctly.

Thank you.

FP

  • You must to post comments
0
0

Oh, and while I have you reading…any answers to my other post regarding surround panning?

😉

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.