0
0

Hello,

I searched a bit and couldnt find the exact topic on this so posting anew. I have a stream with flags:

FMOD_CREATESTREAM | FMOD_2D | FMOD_SOFTWARE | FMOD_OPENMEMORY_POINT | FMOD_NONBLOCKING

and all works well when playing a stream. However, if I alt tab the FMOD_CHANNEL_CALLBACKTYPE_END is called to my callback function specifying that it ended… When it certainly most did not. Is there another init flag I need to give to either the system or sound to just make it continueing where it left off if it gets starved of data?

Thanks.

  • You must to post comments
0
0

Most likelly your System::Update stopped being called so it starved.

You should place the update in your application in a spot that acutally runs while the application is not in focus.

  • You must to post comments
0
0

Have you looked in the docs for FMOD_OUTPUTTYPE_DSOUND (I’m assuming you’re on Windows)? It looks like using the extradriverdata parameter with System::init might help:

"extradriverdata is a pointer to a HWND so that FMOD can set the focus on the audio for a particular window."

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.