0
0

I am experiencing the following situation on both PC and Xbox:

All fully occluded 3d events I play are momentarily audible, only becoming inaudible a little while after playing (instead of instantaneously), giving strange bursting sounds. Of course these sounds should never be audible, seeing as they are fully occluded.

The occlusion callback tells me the occlusion factor is 0 the first time the callback is fired (should not be) – this happens to fire straight after event->start() – and then subsequent callbacks indicate it is greater than 0 (should be).

I always update the 3d listener attribs immediately before updating the event system.

Anyone experienced this? Suggestions would be appreciated.

  • You must to post comments
0
0

Solved!

Our virtual 3d sound system led to the following:

  1. Get event handle
  2. event->setPaused( true )
  3. event->start()
  4. [Event comes in range]
  5. event->set3DAttributes( … )
  6. event->setPaused( false )

The problem here, I found, is setting the 3D attribs [b:3lciav1p][i:3lciav1p]after[/i:3lciav1p][/b:3lciav1p] starting the event – I thought that pausing and then starting the event means that it never plays, when indeed it actually does (hence the occlusion factor being "wrong" the first time i get the callback).

Changing this to:

  1. Get event handle
  2. event->set3DAttributes( … )
  3. event->setPaused( true )
  4. event->start()
  5. [Event comes in range]
  6. event->setPaused( false )

resolves the issue …

Would be really nice if there was a "start paused" function in FMOD. Is there? Obviously my setPaused( true ) then start() approach doesn’t work …

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.