0
0

I have an event with a param 0-5 and velocity=1.0 that has a single sustain point at 2.
The sound is keyed off, and then often restarted by resetting the param to 0.
This usually works, but if the param is keyed off, reset to 0, then keyed off and reset again before it has reached the sustain point, the sustain point will be ignored for as long as the event instance exists.

Is this a known problem or just a user problem ๐Ÿ˜‰ ?

We’re using api 4.12.04 in this project (designer 4.13.04).

  • You must to post comments
0
0

[quote="raek":33m32xz0]I have an event with a param 0-5 and velocity=1.0 that has a single sustain point at 2.
The sound is keyed off, and then often restarted by resetting the param to 0.
This usually works, but if the param is keyed off, reset to 0, then keyed off and reset again before it has reached the sustain point, the sustain point will be ignored for as long as the event instance exists.

Is this a known problem or just a user problem ๐Ÿ˜‰ ?

We’re using api 4.12.04 in this project (designer 4.13.04).[/quote:33m32xz0]

Is this just happening in Designer or in EventPlayer and game too?
If you haven’t already can you try to reproduce this problem in Event Player?

cheers,
Templar

  • You must to post comments
0
0

[quote="Templar":zp4pmgu6]
Is this just happening in Designer or in EventPlayer and game too?
If you haven’t already can you try to reproduce this problem in Event Player?
[/quote:zp4pmgu6]
Only in game. Suspect I can’t be fast enough to reproduce in event player. Have to catch the param slider with mouse to rewind.

(Of course game might scrw it up. But I monitor the actual value by event->getParameter(index) and ->getValue(…), and it does pass right by its sustain point.)

  • You must to post comments
0
0

[quote="raek":3ez2fwg5](Of course game might scrw it up. But I monitor the actual value by event->getParameter(index) and ->getValue(…), and it does pass right by its sustain point.)[/quote:3ez2fwg5]

time and time again, and the reason could be overzealous keyoffing. Ie not a problem in FMOD…

I’ll get back if I still think I have a problem after some more tests.

Thanks for your time!

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.