0
0

Hi guys, I have a piece of code (Delphi) to set up a graphic eq in my app that works perfectly under version 4.6.19 but crashes with v4.20.

Here is the code :- (dobug is my own internal reporting function)

for x:=1 to 12 do begin
if fmod.FMOD_System_CreateDSPByType(FmodSystemFB, FMOD_DSP_TYPE_PARAMEQ, FMeq[x])<>FMOD_OK then dobug(‘DSP not created’);
if fmod.FMOD_System_AddDSP(FmodSystemFB, FMeq[x])<>FMOD_OK then dobug(‘EQ channel filter not added’);
if fmod.FMOD_System_Update(FModSystemFB)<>FMOD_OK then dobug(‘Not Updated’);
fmod.FMOD_DSP_GetActive(FMeq[x],isactive);
if not isactive then dobug(isactive) else begin
if fmod.FMOD_DSP_SetParameter(FMeq[x],0,eqparam[x,1])<>FMOD_OK then dobug(‘Centre Parameter not set’);
if fmod.FMOD_DSP_SetParameter(FMeq[x],1,eqparam[x,2])<>FMOD_OK then dobug(‘Bandwidth Parameter not set’);
if fmod.FMOD_DSP_SetParameter(FMeq[x],2,eqparam[x,3])<>FMOD_OK then dobug(‘Gain Parameter not set’);
end;
if fmod.FMOD_System_Update(FModSystemFB)<>FMOD_OK then dobug(‘Not Updated’);
end;

This all used to work perfectly but it now crashes. Any idea what I’m doing wrong?

Thanks all.

  • You must to post comments
0
0

If you can produce the problem in C/C#/VB or C++ we can help, but not in delphi. I’m assuming the issue is with your delphi wrapper. We had a sort of functioning version a while back but we removed it in recent releases.

  • You must to post comments
0
0

Can you tell me which version to download to get the last Delphi wrapper you created? Why are you dropping your Delphi support?

  • You must to post comments
0
0

[quote="brett":2fhqax7g]The delphi interface was badly maintained , and not even created by us. It fell into disrepair so we didnt want it in our api.[/quote:2fhqax7g]
http://52.88.2.202/forum/viewtopic.php … ght=delphi

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.