0
0

When toggling between using set3dpanlevel(0.0) and set3dpanlevel(1.0), I’ve noticed a big sound difference that occurs in the most recent release of fmod, and previous.

getAudibility returns 1.0 for both set3dpanlevel(0.0) and set3dpanlevel(1.0), (as it should, as the listener position is within range) yet the 3d sound is muffled slightly. The 2d version (when using set3dpanlevel(0.0) ) plays at the appropriate volume level.

getAdubility() is checked after setPaused( false ) is called.

Why would there be a volume difference?

Thanks

  • You must to post comments
0
0

Woops, apologies, it looks like it’s because the sound is playing on the center channel only when using set3dpanlevel(1.0). Ugh.

Is there a way to have 3d positioned sounds play on the left and right speakers if they’re close enough? The transition is instantaneous between speaker channels… argh.

  • You must to post comments
0
0

Channle::SetSpeakerMix I think is what you are looking for…

  • You must to post comments
0
0

It is not instantaneous unless you are moving the sound directly through the listener position. Otherwise (ie if the sound is circling your head) it smoothly pans between pairs of speakers.

If you dont want to use the center speaker at all disable it from 3d calculation with System::setSpeakerConfig

  • You must to post comments
0
0

Nope, it litterally only comes out of my center channel if a sound is in front of me. The transition between center and left/right speakers happens too quickly.

I’ll turn to face a looping sound, and it plays in the center channel. I’ll turn the camera about 30 degrees to my left, and it then switches to the right speaker (but nothing is coming out of the center speaker anymore)

Problem is, when you’re really close to a sound source, and you’re facing it, it doesn’t come out of the right or left channels — it only comes out of the center channel. The center channel doesn’t have much umpf.

  • You must to post comments
0
0

Is the listener and the playing sound at exactly the same height(z)
Set your listener position a little higher or lower than the playing sounds, like 5 units. This should prevent the sound from switching too abruptly from one speaker to the other.

  • You must to post comments
0
0

you must have a problem with your orientation vectors or something, they are not perpendicular or unit length. The 3d example does almost exactly what you’re saying, moves a sound in front of you, also the geometry example is a proper 3d app it doesnt have that problem you could probably use it to compare what is wrong with your implementation.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.