0
0

when running the pitchdetection example on a 1st gen iPhone with OS 2.2, i get a EXC_BAD_ACCESS signal. this does not happen on the simulator. it seems to occur at the recordStart call.

// result = system->recordStart(0, sound, true);

[…]
FMOD: OutputSoftware::createSample : done
FMOD: SystemI::createSample : done
FMOD: SystemI::createSoundInternal : No name found in file, use filename.
FMOD: SystemI::createSoundInternal : done. OpenState now = FMOD_OPENSTATE_READY.

FMOD: SystemI::recordStop :
FMOD: SystemI::recordStop : done
[Switching to thread 12035]
[Switching to thread 12035]
Program received signal: “EXC_BAD_ACCESS”.

  • You must to post comments
0
0

That is interesting, I have the reverse problem. I always get a crash when using the simulator but never on the device. Testing here with an iPhone 3G, OS 2.2.

The crash on the simulator is known and due to the Apple SDK which will be hopefully fixed in the future SDK release. It hasn’t been a major concern since recording works fine on the device (so we have found from our tests anyway).

However you seem to be getting the problem on the device. If you could answer the following questions hopefully I can get the problem reproducing here.

Does it crash every time you run the application? or randomly? Does it crash in Debug only? Do you get the same problem with the recording example? Are you using the latest release of FMOD?

  • You must to post comments
0
0

Hi,
whenever i m trying to run recording and click on record everytime, it gives error on iphone simulator with debug, release, iphone sdk 2.0, 2.1 and 2.2 option. however i have not tested on real iphone device. but can anyone suggest me solution for running example on iphone simulator?

Thanks in advance.

  • You must to post comments
0
0

This is a known bug, you can see it mentioned in the platform specific section under iPhone in the docs CHM file. The problem is with the Apple iPhone SDK, not FMOD.

We have been trying to get this resolved with Apple, but turn around times on bugs has been slow.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.