0
0

Hi,

I’m trying to stop and resume all the sounds played by fmod when going in and out of the Wii home menu. What I’m doing is getting the category "master" and pausing/resuming everything. This works fine for pausing, but somehow the sounds played on the Wiimote don’t seem to resume correctly. I have to play them again one by one if I want them back.

Is there another way to do that, or did I miss something ?

  • You must to post comments
0
0

Hi,

There was a bug fixed recently that is probably related to this. The fix is in the latest versions:

4.16.25 / 4.18.15 / 4.20.06 / 4.21.06

[quote:25b8lfe0]
– Wii – Fixed WiiMote staying mute when "muteremotespeakerifnosound" is set if
the WiiMote speaker is turned off then on.

[/quote:25b8lfe0]

  • You must to post comments
0
0

Thanks for the quick reply. I was finally able to test the new version, and it looks like there still is the same problem.

Could it be that the Wiimote on which to play the sound is somehow "forgotten", and I’d have to set it again after unpausing to really resume the sound ?

  • You must to post comments
0
0

It is possible. The sounds playing out of the WiiMote are usually very short, so I’m not sure it is even a big deal if they don’t continue after coming out of the hbm?

There is a homebutton example included in the FMOD SDK that you might find helpful.

  • You must to post comments
0
0

[quote="chenpo":1p3n5jrg]It is possible. The sounds playing out of the WiiMote are usually very short, so I’m not sure it is even a big deal if they don’t continue after coming out of the hbm?

There is a homebutton example included in the FMOD SDK that you might find helpful.[/quote:1p3n5jrg]

They are indeed very short, but they could be repeated, which is the case here. I’ll take a look at the sample anyway, see if I can find some useful snippets 😉

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.