0
0

Hi! One of channels within group was stopped with probability 5-10% after setting pause for this group.
This was happen ONLY on Windows XP (Vista was OK) then I use streamed sound.

For reproduce this bug You can use sample from FMod_Ex – playstream. You have to add this to message process:

[code:16gb58ok]case ‘p’ :
{
FMOD::ChannelGroup* masterGroup = NULL;
system->getMasterChannelGroup(&masterGroup);
if (masterGroup)
{
bool paused;
masterGroup->getPaused(&paused);
masterGroup->setPaused(!paused);
}
break;
}[/code:16gb58ok]

Music was stopped after multiple pause switch (50-100 swithes, sometimes immediately).
For increasing chance of this you can add more channels to this group.

FMOD Ex (Stable) Version: 4.20.06 was used.

  • You must to post comments
0
0

Hi all.

Somebody can help us?

  • You must to post comments
0
0

Thanks I found a race condition that causes this.
The solution for this is use FMOD_SOFTWARE instead of FMOD_HARDWARE. Future versions of FMOD will not even support hardware/directsound at all so it won’t matter.

I’ll patch it anyway for the next release.

  • You must to post comments
0
0

Thanks, it’s work with FMOD_SOFTWARE flag.

This bug also did not occur with FMOD_INIT_STREAM_FROM_UPDATE flag in init engine (use hardware channels).

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.