0
0

There does still seem to be an issue with the non-blocking flag. I discovered this on accident, but after i did some tests, i noticed that a file path length of 130 or more characters fails to load properly when FMOD_NONBLOCKING flag is used. if I remove the flag, it will play. the code below is what i use to open the stream.
[code:3mawgqi0]
FMOD_MODE fmodMode = FMOD_SOFTWARE | FMOD_UNICODE | FMOD_MPEGSEARCH | FMOD_NONBLOCKING;

//open the stream
//fmodRes = fmodSystem->createStream((char*)CurrentSong->GetFile(), fmodMode, NULL, &fmodSound);
fmodRes = FMOD_System_CreateStream(fmodSystem, (char*)CurrentSong->GetFile(), fmodMode, NULL, &fmodSound);

[/code:3mawgqi0]

if I just remove the FMOD_NONBLOCKING flag, all is well.

The createStream function returns FMOD_OK, but getOpenState returns the error. I use the unicode flag becuase my whole player system is in unicode and certain filenames are unicode characters. But it seems that when using the non-blocking flag, the length of the path name is cut in half, from 260 to 130.

  • You must to post comments
0
0

Thanks for the report! This will be fixed in the next release.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.