Im studying computer sciences in a school where FreeBSD has been setup on the computers. I have to make a project which deals with sound and I need FMOD. First of all, you got to know that I cannot use the computer as if it was mine and to use FMOD I must do :
gcc main.c -o main -L./FMOD -flmod-3.75 . (DIR FMOD/ fmod-3.75.so)

Then I see :
/usr/bin/ld: warning: libc.so.6, needed by ./FMOD/libfmod-3.75.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libdl.so.2, needed by ./FMOD/libfmod-3.75.so, not found (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libm.so.6, needed by ./FMOD/libfmod-3.75.so, not ffound (try using -rpath or -rpath-link)
/usr/bin/ld: warning: libpthread.so.0, needed by ./FMOD/libfmod-3.75.so, not found (try using -rpath or -rpath-link)
./FMOD/libfmod-3.75.so: undefined reference to getenv@GLIBC_2.0'
./FMOD/libfmod-3.75.so: undefined reference to
./FMOD/libfmod-3.75.so: undefined reference to free@GLIBC_2.0'
./FMOD/libfmod-3.75.so: undefined reference to
./FMOD/libfmod-3.75.so: undefined reference to inet_addr@GLIBC_2.0'
./FMOD/libfmod-3.75.so: undefined reference to
./FMOD/libfmod-3.75.so: undefined reference to `tan@GLIBC_2.0′

So I guess I need to find an old version of FMOD which isn’t linked to libc 6. (Because I cannot install libc.so.6 on the school computer)
Ive been looking for and old version of FMOD for a long time but i didn’t find anything. Where else can I find something like that ?

best regards


  • You must to post comments
Showing 0 results
Your Answer

Please first to submit.