0
0

I’m trying to update FMOD from version 42001 to 42202 I’ve got everything on the code side set up but now I need to build the new FEV and FSB files. Every time I start building the second FSB it crashes. If I look in the fmod_designer.log I get:

Warning: ASSERT: "i <= nodes" in c:\qt\3.3.5\include\qvaluelist.h (373)

What does this mean and how can I fix it?

  • You must to post comments
0
0

This seems to happen to every FSB after the first one. This is a fairly large project right now, so I would like to avoid having to re build this project by hand.

  • You must to post comments
0
0

Found the problem. Apparently when I upgraded to 4.23.xx all my GUIDs got set to the same one. I had to open all of my events and regenerate their GUIDs. Is there a button somewhere to just regenerate all? Because it wasn’t fun open all the folders to regenerate all the GUIDs.

  • You must to post comments
0
0

To regenerate all the GUIDs you can just press Ctrl-A to select all in the event hierarchy view, then right-click and select "Regenerate GUIDs". It doesn’t matter if there are event groups that aren’t open – the events within them will still be selected.

Designer shouldn’t crash if there are duplicate GUIDs. Are you sure this was the cause of the crash? There was another crash when building FSBs that is fixed in the latest version (4.23.04).

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.