0
0

Well, It took me a long time to figure it out, but FMOD designer defaults sound banks to PCM. I have found that this does not work on many computers that I have used. Originally, it took me about 4 – 8 hours and searching the internet to figure out that all I have to do is change the sound bank to ADPCM or MP2/MP3.

In Designer, an "Invalid Parameter" is spit out on the 3D event. Changing the soundbank type will fix this error. Your error messages are unintuitive and have wasted a lot of hours of my time.

I love fmod designer for what it can do, but this error has plauged me and gamerakana for many hours and it should be changed in future versions or at least talked about in the documentation.

thanks,

stringa

  • You must to post comments
0
0

Try setting Force Software to Yes in the bank, and see if that also fixes it, could be a hardware/driver issue.

  • You must to post comments
0
0

I’m not asking how to fix it, as I already know how. What I’m saying is that nothing talks about that in the FMOD documentation. And invalid parameter sent in the FMOD gui should be a little more descriptive. Also, spending 4 – 12 hours on a simple little flag is ridiculous. It happened to me and it just happened to my buddy.

  • You must to post comments
0
0

The reason this is not in the FMOD documentation is that it is not intended behaviour (i.e. it sounds like a bug). Is there any chance you could send the FDP and wave file that gives the "Invalid Parameter" error to support@fmod.org so we can try to diagnose the problem?

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.