0
0

What MP3 BitRate/SampleRates are supported, using the FSOUND family?
I get this error: FMOD_ERR_FILE_FORMAT (10 decimal) for some MP3’s. In every instance I’ve checked so far, they were not the standard 128/44100. For example the last error occurred on an MP3 with 256/32000. Perhaps a different constant in the Stream Open call?

BTW, all of the MP3’s which errored in FMOD played OK in WinAmp.

  • You must to post comments
0
0

Hmmm, interesting. I have no problem playing 96,128,256,320 kbps MP3’s in v3.6. So I dont know what the problem could be.

  • You must to post comments
0
0

What samplerate did you INIT with? And, what flags are you using on load?

  • You must to post comments
0
0

I was just using 44100 for FSOUND_Init and FSOUND_2D for FSOUND_Stream_OpenFile as shown in Sample1.

After looking at the prjDMPFinal example posted on this board, I tried this init:
FSOUND_Init 44100, 64, FSOUND_INIT_ACCURATEVULEVELS Or FSOUND_INIT_GLOBALFOCUS
and this open:
Stream = FSOUND_Stream_OpenFile(filename, FSOUND_2D Or FSOUND_MPEGACCURATE, 0)

but it still gives the format error on an MP3 with BR/SR=256/32000.

I also tried changing the init SampleRate to 32000 but got the same error.

  • You must to post comments
0
0

It should support it, it’s true MPEG-1 Layer 3.

  • You must to post comments
0
0

Maybe these files have a very large tag at the beginning?
I had some files that didn’t open correctly because the tag was too long.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.