0
0

Hello,
I have a project where I use both 2d and 3d sounds with some of them being affected by a reverb.

Now it seems that if I listen to the project through a surround system (7.1) the 3d events all get reverb eventhough I’ve set their wet level to -60. The 2d events work as intended. If I use a normal stereo system the events all play correctly 3d or not.

So is there something I’ve missed? Do 3d events always get reverb in surround systems?
I use version 4.25.08

  • You must to post comments
0
0

I really can’t figure this one out… I’ve tried the project on windows both with a standard stereo desktop speaker system and a 7.1 surround system. With the standard stereo system always plays it right while the 7.1 surround system results in all 3d events gettting reverb regardless of their wet settings.

I’ve tried deleting the reverb definition that is doing this, and since this turns off the reverb I conclude that it’s the reverb I’ve defined that is turned on when played through a surround system.

Has no one else run into this?

  • You must to post comments
0
0

I have this problem!

I will warn you I am a beginning user.

However, fresh install of 4.25 on WinXp x64, and this problem cropped up immediately in the tutorial, "simulating distance". I have a 5.1 configuration that works correctly for multiple software and hardware sources (e.g. several versions of Cubase, Windows Media Player; XBOX 360).

In the tutorial you create a 3-D event, add reverb, and add separate control curves for wet and dry signals. The control curves for the Wet (reverb) signal have no effect.

Has there been some minor adjustment in logical handling of the reverb signal path? I mean, can someone who regularly uses 3D reverb in FMOD sit down and follow the chapter 5 tutorial [i:29kysllg]exactly as written, without adding any steps no matter how elementary[/i:29kysllg] and see if they get this result?

  • You must to post comments
0
0

marten_b: [i:2r62q3j8]"Do 3d events always get reverb in surround systems?"[/i:2r62q3j8]

The tutorial makes it clear that this is not (supposed to be) true. In the tutorial you handle the occlusion and volume of the Reverb with their own control curves. These steps are explicit. The result is supposed to be that the occluding dry signal blends into the reverb. The reverb stays at a stable volume for a moderate distance as the dry signal is further occluded and faded out. Then the Reverb is faded out. You are invited to listen for the effect.

Clearly, FMOD is designed to provide control over all parameters of all effects — per-signal, per-layer. Discrete signal paths have discrete controls. So [i:2r62q3j8]something[/i:2r62q3j8] is definitely going wrong for us.

  • You must to post comments
0
0

I have created the SimDistance event, as well as another event with no dry signal which sets the wet volume using the distance parameter.

[b:3cu9somz]marten_b[/b:3cu9somz]

I’m not sure why you are getting 100% reverb on all events. Can you try playing your events in EventPlayer and see if the reverb still misbehaves?
It might be worth sending your project to support@fmod.org and we can take a look.

[b:3cu9somz]Slumberland[/b:3cu9somz]

I tested the events in both Designer and EventPlayer (only in stereo), and in both apps the reverb level was controlled as intended.

cheers,
Templar

  • You must to post comments
0
0

Hi,

Yeah I’ve tried it in the Event player and it acts correctly there, so it’s only when we play it in our game this problem arises.

I’ve sent an email to the support address with a attached project to it. Hope you can find something!

/Mårten

  • You must to post comments
0
0

Just to follow up, this turned out to be a hardware specific issue and was resolved when Force software was turned on for the corresponding wavebanks.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.