0
0

Hi
First , Thank you for FMOD, Its a great sound system.
After creating a sound(About 4 minute audio file) in 2D mode, FMOD take 50 MB of my RAM(Even with FMod\Demos\PlayList)
If i create the sound in 3D space(that have other sound sources), then it take more than 500 MB!?
Why? What is wrong ? Is it any option that i reduce memory usage of FMOD?
Notes:
1) File format is not important in the above problem, reducing wav or mp3 quality don’t help.
2) Adding the sound source to empty scene take 50 MB and to not-empty scene take 500+MB of RAM.
3) Im using FMOD EX 4.22.02 (30/01/09 – Stable branch update.)
4) Reducing length of sound file, can reduce the problem. but its impossible that i cut the sound file,because the sound file is a voice and must i play it fully in a 3D sound space.

Thank you for any help.
H.Ahmadi

  • You must to post comments
0
0

[quote="Ahmadi":c38nqih3]Hi
First , Thank you for FMOD, Its a great sound system.
After creating a sound(About 4 minute audio file) in 2D mode, FMOD take 50 MB of my RAM(Even with FMod\Demos\PlayList)
If i create the sound in 3D space(that have other sound sources), then it take more than 500 MB!?
Why? What is wrong ? Is it any option that i reduce memory usage of FMOD?
Notes:
1) File format is not important in the above problem, reducing wav or mp3 quality don’t help.
2) Adding the sound source to empty scene take 50 MB and to not-empty scene take 500+MB of RAM.
3) Im using FMOD EX 4.22.02 (30/01/09 – Stable branch update.)
4) Reducing length of sound file, can reduce the problem. but its impossible that i cut the sound file,because the sound file is a voice and must i play it fully in a 3D sound space.

Thank you for any help.
H.Ahmadi[/quote:c38nqih3]

Try using
FMOD_System_CreateStream()

for huge (long playing time) files

  • You must to post comments
0
0

Thank you, the problem solved.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.