0
0

Hi,

We’re trying to use the Master Volume slider to reduce the overall volume of our game and it doesn’t appear that such changes are being included when we build the project. However, when we use the Audition feature and manipulate the Master settings it affects the game. Is there something that needs to happen on the code side for the Master parameters to be recognized? Perhaps I’m building the project incorrectly?

Not sure if this would affect things, but we have an .fdp for SFX and a separate .fdp for music. I thought the problem might have been that the Master Volume in the SFX .fdp and music .fdp didn’t match, so the engine just defaulted to 0dB, but this doesn’t seem to be the case. I set them both to -60dB and there was no change when using the built project files.

I tried an older version of designer in case that was the problem, but that didn’t solve the issue either. We’re currently running Designer version 4.23.05.

Thanks,
Sean

  • You must to post comments
0
0

[quote="capybara":ywit2hyt]We’re trying to use the Master Volume slider to reduce the overall volume of our game and it doesn’t appear that such changes are being included when we build the project. However, when we use the Audition feature and manipulate the Master settings it affects the game. Is there something that needs to happen on the code side for the Master parameters to be recognized?[/quote:ywit2hyt]
I assume you’re talking about the master category volume here? If so, you’ll need to pass an FMOD_EVENT_LOADINFO structure to EventSystem::load and set the override_category_vals member to true when loading the FEV that specifies the master category’s volume.

The reason you need to do this is that by default the event system doesn’t override category volume and pitch if the category already exists when loading an FEV. Because the master category always exists (it is created when the event system is initialised), you need to specify override_category_vals if you want to set its volume from an FEV.

  • You must to post comments
0
0

Thanks, Ben. Yes, that’s what I was referring. This solved the problem for us.

Thanks again,
Sean

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.