0
0

Hi,

I recently had to migrate my local copy of audio sources to a different drive. I changed the path in the "Audio Source Directory" accordingly, but found that when I went to build, I was getting errors indicating fmod could not find certain assets. When I looked at these, it appears that fmod is still using an absolute drive reference on some files, but not with others.

This is slightly annoying, to say the least. Am I doing something wrong, or is this a bug?

Eg : Original source C:\sounds\
New Source : D:\Sounds

Fmod builds most of the sounds fine, then hits certain sounds where it says : Could not find wav "C:\Sounds\thatsound.wav"

Checking the original sound definitions indeed most sounds say "\sounds...wav" but for some reason a handful say "C:\sounds.…wav"

Mysterious indeed.

Thanks.

  • You must to post comments
0
0

Don’t know about the cause, but I’d look at the .FDP file in a text editor – it’s XML.

Try a search and replace for:

from: <filename>c:\sounds\
to: <filename>sounds\

or whatever your case may be.

Of course, keep a backup of your FDP file before hacking at it in a text editor :)

  • You must to post comments
0
0

Thanks for this, you’ve saved me about 12 hours’ work :)

  • You must to post comments
0
0

I’m having a problem like it, as I get used to Fmod.

I have the current wav files here: D:\ProjectAudio\Pitch
There I have the wavs sorted in 3 directories, SFX, MUSIC, and AMBIENT

Now I want to move everything, and the wavs end up here:
C:\Users\Hanneke\Desktop\Audio\Pitch

with the same sub directories.

Previously, the "Audio Source Directory" field was emtpy. I tried to full in various versions of the path, but to no avail it seems.

Did I do something wrong? How should I go about moving my FMod working directory?

  • You must to post comments
0
0

[quote="Hanneke":21b7vlwu]Did I do something wrong? How should I go about moving my FMod working directory?[/quote:21b7vlwu]
You should be able to fix this reasonably easily:
[list=1:21b7vlwu]
[:21b7vlwu] Rename the old wave file directory (D:\ProjectAudio\Pitch) temporarily so Designer can’t find the old wave files[/:m:21b7vlwu]
[:21b7vlwu] Set your audio source directory to the new location (C:\Users\Hanneke\Desktop\Audio\Pitch)[/:m:21b7vlwu]
[:21b7vlwu] Build your project (uncheck the wave banks so the build is quicker)[/:m:21b7vlwu]
[:21b7vlwu] Designer will show a dialog with the text "<filename> couldn’t be opened for reading. Please specify the file’s location."[/:m:21b7vlwu]
[:21b7vlwu] Click OK[/:m:21b7vlwu]
[:21b7vlwu] Designer will show a "Find <filename>" dialog[/:m:21b7vlwu]
[:21b7vlwu] Navigate to the new location of the specified file and click OK[/:m:21b7vlwu]
[:21b7vlwu] Repeat steps 4 to 7 until all waveforms are found. Designer searches previously visited directories for each missing waveform, so in your case you should only have to repeat 3 times (since you only have 3 different directories).[/:m:21b7vlwu]
[:21b7vlwu] Your waveform paths should now be relative to the audio source directory[/:m:21b7vlwu][/list:o:21b7vlwu]

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.