0
0

Hi,

we have some weird performance issues with FMOD on the Wii. Audio seems to really affect our performance.
After profiling I’ve found that ASfxDsp::DoDSPProcessing takes a lot of (11% when total is 35%) time, when the rest is used by audio thread sleep function.

I’m quite sure that I’ve just missed some flag, or setting. Can you please give me some ideas for what might be wrong?


greetings,
Piotr

  • You must to post comments
0
0

That is the reverb. If you’re on wii you can disable all software mixing using the FMOD_INIT_SOFTWARE_DISABLE flag.
If you need software for some other reason then you will want to turn off reverb. I can see you might also want hardware reverb for hardware sounds but not software reverb for software sounds. Currently that isn’t possible so we’d need to add some sort of flag to allow you do to that. setReverbProperties wraps both hardware and software calls to reverb simultaneously.

Next time please keep console related posts in the console forum thanks.

  • You must to post comments
0
0

Thank you. It’s all sorted for us now. I’ll remember to ask in the right forum next time.


greetings,
Piotr

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.