0
0

In the Designer it’s set in both the event tab and the Sound Definition tab to have 5 instances of a sound to play, but it won’t play more than one at a time.

To play multiple instances of the same sound event, would I need to call get event every time I need to play one? I’m kind of baffled, because this happens for all my sounds.
I thought it could be a channel thing, but even if it was, I don’t have direct access to the Channels to check as far as I know.

  • You must to post comments
0
0

[quote:767wiqur]To play multiple instances of the same sound event, would I need to call get event every time I need to play one?[/quote:767wiqur]
Yes, getEvent returns a single event instance.

-Pete

  • You must to post comments
0
0

[quote:ww2h8ztl]Yes, getEvent returns a single event instance. [/quote:ww2h8ztl]

So say I have a sound event called "Button Hover". When I wanto play button hover say 3 times before any of the events have finished I have to call getEvent again, and not just play on the same instance I received previously?

  • You must to post comments
0
0

[quote:3is01xrx]When I wanto play button hover say 3 times before any of the events have finished I have to call getEvent again, and not just play on the same instance I received previously?
[/quote:3is01xrx]
correct

  • You must to post comments
0
0

my goodness, Ive been doing it wrong this whole time. Thanks, I got it to work.

Thanks so much! 😀

  • You must to post comments
0
0

You’re welcome. I’m glad to hear you got it working :)

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.