0
0

My C# program works fine using FMOD on Windows. But on Linux the call to Fmod.createSound returns ERR_UNSUPPORTED. Is this about the combination of MODE flags I have set? How do I determine which one is the unsupported one?

I am using 3D features.

  • You must to post comments
0
0

[quote="m37cue":1trygnuz]My C# program works fine using FMOD on Windows. But on Linux the call to Fmod.createSound returns ERR_UNSUPPORTED. Is this about the combination of MODE flags I have set? How do I determine which one is the unsupported one?

I am using 3D features.[/quote:1trygnuz]

FMOD_HARDWARE maybe? That would be my guess, try
FMOD_SOFTWARE

  • You must to post comments
0
0

Half the time I get FILE_BAD and the other times I get UNSUPPORTED on the createSound call. I know that the file exists because I put in a test File.Open of it just before calling createSound to check. (and close it again).

What is the exact list of conditions that can lead to the BAD_FILE status being returned? All the CHM says is "Error loading file". (The same code works fine on Windows)

The file is a 16kHz mono file created by the Festival synthesizer.

  • You must to post comments
0
0

I notice that the C# wrapper is not included in the Linux download. Does the C# wrapper not work with mono? I wrote the C# equivalent of the "playsound" C demo, and it still fails with FILE_BAD on createSound.

  • You must to post comments
0
0

It seems that FMOD does not like Unicode filenames on Linux. (Passed in from C#) We modified fmodex-dotnet.dll to use ASCII encoding on those parameters.

  • You must to post comments
0
0

There is an FMOD_UNICODE flag that you can pass into createSound. You might need to do that in c# for it to like your strings.

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.