0
0

Fmod does not recognize [b:2ftxi0zj]hint { }[/b:2ftxi0zj] elements in my asound.conf:

[code:2ftxi0zj]pcm.!default {
type plug
slave.pcm "multiplex"
hint {
show on
description "default default"
}
}[/code:2ftxi0zj]

It returns "ALSA lib pcm.c:2211:(snd_pcm_open_noupdate) Unknown PCM default".

More information: http://forums.savage2.com/showthread.php?t=18926&page=2

  • You must to post comments
0
0

bump

  • You must to post comments
0
0

FMOD does not parse the hint block. However if you have a newer version of ALSA it will use the name hint API to give more detail in the enumerated device list.

The problem is probably the exclamation mark before default, can you use FMOD to enumerate your devices and post the results here. I believe the recording example does this.

The exclamation mark is for parameter overriding in the file, but I think FMOD is picking it up as a device name.

  • You must to post comments
0
0

I believe that’s not the problem, because when I comment out [i:bw12i3un]hint { }[/i:bw12i3un], it works again, even with [b:bw12i3un]![/b:bw12i3un].
By logic, the only thing stopping my sound configuration from working with FMOD is [i:bw12i3un]hint { }[/i:bw12i3un].

  • You must to post comments
0
0

Ok I have done some testing. It would seem that the hint information coupled with the querying of it via the ALSA API is causing a corruption that is preventing the load of the device.

There are bugs in ALSA with the name hint API we use for enumeration, we have worked around them a couple of times but it seems this is another side affect it of it.

For now I would recommend removing the hint entry from your ALSA config.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.