0
0

Hi,

I have some problems using Teamspeak 3 with Linux (Ubuntu 9.10). They say it’s caused by the fmod library. That information is from 21st December. Are there any news on this?

The whole program crashes when I try to use, test or setup my sound configuration.

mfg Maddink

  • You must to post comments
0
0

It looks like progress is being made on the alsa-plugin problem based on the posts in that link you provided. Hopefully the fixed version filters down to the update systems soon.

We are reluctant to do a PulseAudio backend as we already support 3 other backends, OSS, ALSA and ESD. If it comes down to necessity we will add a PulseAudio backend, but we are not quite at that point yet.

  • You must to post comments
0
0

We are in talks with Teamspeak at the moment trying to reproduce the problem here on our machines for debugging, so far that has been unsuccessful.

I believe the problem is PulseAudio, the new version that comes with Ubuntu 9.10 is causing problems with our code for some reason, code that works fine with previous version of Ubuntu and other distros.

If you could send us the contents of your "/etc/asound.conf" and "~/.asoundrc" files (if they exist) that may help debugging. Also as a temporary workaround you could try using "pasuspender", this will suspend PulseAudio while you run a particular application such as Teamspeak.

  • You must to post comments
0
0

hi, their have been alot of updates to pulseaudio but nothing has fixed this issue within teamspeak. CPU usage is still jumping from 80-100% and the audio is lagging, client crashing. tested this on ubuntu 32bit 9.10

http://forum.teamspeak.com/showthread.p … 202&page=3

  • You must to post comments
0
0

Hi,

thanks for your quick reply. I could not find the asound.conf file. I only found the .asoundrc in my home directory. It contains:

ALSA library configuration file

Include settings that are under the control of asoundconf(1).

(To disable these settings, comment out this line.)

</home/xxxx/.asoundrc.asoundconf>

It only links to the file .aoundrc.asoundconf. This only contains:

ALSA library configuration file managed by asoundconf(1).

#

MANUAL CHANGES TO THIS FILE WILL BE OVERWRITTEN!

#

Manual changes to the ALSA library configuration should be implemented

by editing the ~/.asoundrc file, not by editing this file.

I can’t find the file with the real settings at the moment. :-(

mfg Maddink

  • You must to post comments
0
0

I have sent a ping back to the TeamSpeak guys to see where they are at with this issue. Unfortunately we have not been able to reproduce it here on 3 test setups so far, mixed 32bit and 64bit.

  • You must to post comments
0
0

Can you try modifying your ~/.asoundrc file to include the following:

[code:1g8oyo98]
pcm.!default
{
type pulse
}
[/code:1g8oyo98]

Also did you try "pasuspender"?

  • You must to post comments
0
0

I have the same issue with the sound. Mostly it works for for an hour and then it crashes (100-300% cpu usage) and every time I restart TS3 after just some mins it crashes again till I restart my computer.

I think I read that HoN, which I play as well, is/was using fmod for it sound and I had the same problem there. Now they added native pulse audio support and everything works fine.

So my guess is that it’s not bound to TS3 but to fmod and/or ubuntu’s alsa-pulseaudio plugin. I can’t see any problems in the logs I can find but maybe there is some way I can help out, testing or dumps, and if so how could I help?

My asound.conf
[code:2ezzcdkw]pcm.pulse {
type pulse
}
ctl.pulse {
type pulse
}
pcm.!default {
type pulse
}
ctl.!default {
type pulse
}[/code:2ezzcdkw]

  • You must to post comments
0
0

Hi,

I tried to use "pasuspender" but could not get it working. I was not able to launch TS3 with this.

I now tried to modify the asoundrc file and it seems to work. TS ist not crashing down when I use the "automatic sound" for playpack and recording. The processor load is also fine.

I will test it further tomorrow and report back.

Thanks for your help!

mfg Maddink

  • You must to post comments
0
0

This issue doesn’t appear to be going away, which means we are left with two options. The first is wait for PulseAudio / ALSA to fix the plugin that routes ALSA calls into Pulse, which we have been doing. The second is write a PulseAudio backend for FMOD and bypass the problem.

We are pretty busy with preparing for GDC at the moment and have a lot of existing commitments, so the nearest I can schedule supporting PulseAudio natively would be around mid March. If the issue is not resolved via a Pulse / ALSA update by then we will do the new backend.

  • You must to post comments
0
0

Sounds to me like a simple configuration issue, although it should not cause a crash, unless TS isn’t handling the error case properly.

For reference, this site contains the proper setup instructions for PulseAudio:
http://www.pulseaudio.org/wiki/PerfectSetup

  • You must to post comments
0
0

thank you mathew for your professionalism.

FYI, on the teamspeak forums i edited the daemon.conf file in the pulseaudio folder, to the parameters you specified and it did not help in fixing the issue.

http://forum.teamspeak.com/showpost.php … stcount=47

  • You must to post comments
0
0

Hi,

the config tweak seems to work really good.

I changed the Sound settings in TS3 to Alsa too and now I can use Teamspeak, Rhytmbox (audio player) and wow (via wine) together. Only problem is my slow Computer than. But the performance seems to be normal.


EDIT:

It worked for around one hour. Now I have the same problem as before. Every time I try to use it with the automatic setting oder AlSA the cpu load jumps to 100% and TS3 stopps. I can hear with the ESD setting, but cant talk then.

Could you explain what effect the config change has?

mfg Maddink

<- Ubuntu User, no Linux pro :-)

  • You must to post comments
0
0

I think there is a buffering issue going on, the reason for the high CPU is the PulseAudio buffers are emptying and blocking so FMOD is having trouble recovering and filling. Changing the PulseAudio buffer size is one piece of the problem, but changing the FMOD buffer size to be large enough to satisfy PulseAudio is the other.

I don’t think there is an option for FMOD buffer sizes available in TS3 so we are following up the TeamSpeak guys to see if increasing the buffer fixes the starvation issue.

We are hopeful that this issue can be resolved via buffer adjustment, but if not we will continue with our plan for a PulseAudio backend around mid March.

  • You must to post comments
0
0

The config change that I mentioned causes the default ALSA device to be routed through PulseAudio, this is standard setup for PulseAudio as outlined by the URL I provided.

If it was working correctly now it has stopped working what has changed in that time? Have to tried restarting your machine?

  • You must to post comments
0
0

Any news about this here?

  • You must to post comments
0
0

Hi Mathew,

I changed nothing. I played wow and used TS3. After a while (around 1 hour) the fps in wow dropped to 1 and TS3 did not work any longer. I checked the system an TS3 had a realy high cpu load. I closed it through the system and restarted it. But it did not work. No chance to connect to a server or try out the sound setup. The Cou load jumped to 100% in any case.

I did not try a restart.


EDIT:

I restarted now (4 hours later) switched everything back to ALSA and it worked fine. But I did not test it long. (It’s quite late here :-) ). Do you have any idea what happend? Why did it work again after a restart?

mfg Maddink

  • You must to post comments
0
0

Unfortunately no, we are still waiting on TeamSpeak to respond to us regarding our last suggested fix. We heard from them just over a week ago saying it’s on their todo list.

  • You must to post comments
0
0

Without being able to see any crash information I cannot guess as to why it is happening. It sounds to me like an app is taking exclusive control of the sound card causing PulseAudio to fall over.

We will follow up with Teamspeak to try and get it sorted out.

  • You must to post comments
0
0

I’d guess this is a problem in recent versions (included in ubuntu 9.10, etc) of the pulseaudio alsa plugin. There’s been issues (one or more of hangs, static, sound dropping out, no output) using it in certain hardware configurations for a bunch of lower latency alsa-based applications: Skype, Mumble, SDL based applications, FMOD based applications, etc.

Most of them have worked around the problem by adding a pulseaudio backend. Using much larger sound buffers is the other thing I’ve seen that has helped it to work.

There’s a related Ubuntu bugreport at https://bugs.launchpad.net/ubuntu/+sour … bug/485488

  • You must to post comments
Showing 19 results
Your Answer

Please first to submit.