0
0

Today I upgraded from 4.16.08 to 4.28.05. I’m using fmodex.dll, Windows OS.

I can no longer stream music URL’s from the Internet. This is broken. Switching back to 4.16.08 fixes it.

The error given in 4.28.05 by getOpenState is FMOD_ERR_FILE_COULDNOTSEEK (Couldn’t perform seek operation. This is a limitation of the medium (ie netstreams) or the file format.)

The error occurs partway through the buffering. Any seeking is internal, I am not doing any.

Please advise. I get the same result for different URL’s. My app uses http://radio.c64.org:8000

Cheers

Tom

  • You must to post comments
0
0

Can you confirm that the netstream example is showing this same problem, I just tried it here and it worked using the URL you provided.

  • You must to post comments
0
0

Out of the box, netstream does not exhibit the problem with the same URL.

Poking around with it I have isolated the factor that manifests the bad behavior:

  1. Init with FMOD_INIT_VOL0_BECOMES_VIRTUAL
  2. Adjust the volume, e.g:

[code:k8cpubby]
if (!channel)
{
result = FMOD_System_PlaySound(system, FMOD_CHANNEL_FREE, sound, FALSE, &channel);
FMOD_Channel_SetVolume(channel, 0);
}
else
{
FMOD_Channel_SetVolume(channel, 1);
}

[/code:k8cpubby]

This exhibits the problem for me, in netstream.

My app fades in the volume of the music stream.
Omitting either the virtualization flag or the zero volume setting prevents the problem from manifesting.

Thoughts?

  • You must to post comments
0
0

That sounds reasonable to me, you cannot make a netstream go virtual. When a channel goes virtual it stops processing, the virtual channel keeps track of what position it should be up to then when it becomes real again it will seek to the correct position.

The error you are getting is when it becomes "real" it is trying to seek the netstream, which you cannot do. Is there any particular reason why you would want the netstream to go virtual anyway?

  • You must to post comments
0
0

FMOD_INIT_VOL0_BECOMES_VIRTUAL is a System::init flag; I don’t have the ability to disable it for certain sounds, do I?

I had presumed that the flag was intended to give me a performance optimization for most sounds.

Also, as I mentioned, this is an introduced problem. I never had this in 4.16.08.

  • You must to post comments
0
0

Usefulness of the flag depends on what your app is doing. If you have lots of game sounds playing at once with different volumes (some silent) you may get some performance wins by having the silent sounds go virtual. Otherwise it’s probably not helping you at all.

Is it necessary for you game / app to set te volume of the netstream to 0? Could you simply pause or stop it instead?

  • You must to post comments
0
0

Yes, I would expect many of the 3D sounds to go virtual.

My music stream fades in from zero. I’ll try using a low but non-zero volume instead, if that is the best solution.

  • You must to post comments
Showing 6 results
Your Answer

Please first to submit.