0
0

Hello!

I’m trying to use the reverb DSP, but it doesn’t seem to be working.
This is how I apply the effect:

[code:28usfaab]ERRCHECK(system->init(32, FMOD_INIT_NORMAL, 0));
ERRCHECK(system->createSound("../samples/3-1_percussion.wav", FMOD_LOOP_NORMAL, 0, &sound));
ERRCHECK(system->playSound(FMOD_CHANNEL_FREE, sound, false, &channel));
ERRCHECK(system->createDSPByType(FMOD_DSP_TYPE_REVERB, &effect));
ERRCHECK(effect->setParameter(FMOD_DSP_REVERB_ROOMSIZE, 1.0f));
ERRCHECK(channel->addDSP(effect, NULL));[/code:28usfaab]
The sound plays like it would normally and I have no problems applying other effects like flanger, lowpass, highpass, etc.
I use version 4.26.09 on Linux 32 bit.

I also tried using FMOD_DSP_SFXREVERB, but it didn’t do anything either.

I hope you can help me fix it.

Thanks!

  • Abel.
  • You must to post comments
0
0

You need to set reverb properties other than ‘roomsize’ to make it work. For a starting point take a look at the reverb presets in fmod.h, e.g. FMOD_PRESET_CAVE, FMOD_PRESET_HALLWAY, …

-Pete

  • You must to post comments
0
0

[quote="peter":gnxo3myc]You need to set reverb properties other than ‘roomsize’ to make it work. For a starting point take a look at the reverb presets in fmod.h, e.g. FMOD_PRESET_CAVE, FMOD_PRESET_HALLWAY, …[/quote:gnxo3myc]
Thanks for your reply!

I have no trouble now applying the presets on a system level, but when trying to set a reverb per channel (I use 6 channels max) I can not use the presets because they are not compatible with the FMOD_REVERB_CHANNELPROPERTIES structure.

Are there any compatible presets available?

I’m using FMOD in a music application, so environment modelling isn’t of the greatest importance. I want to be able to use reverbs that range from ‘small’ to ‘big’.

Hope you can help me. Thanks again!

  • Abel.
  • You must to post comments
0
0

If it is a music application, is there any reason you can’t just use the system reverb?

FMOD_REVERB_CHANNELPROPERTIES controls how much of the channel signal to send to the system reverb.

If you want to set different reverbs per channel you can create a SFX reverb DSP and use setParameter to manually set the properties.

-Pete

  • You must to post comments
0
0

[quote="peter":3bedymtv]If it is a music appliacation, is there any reason you can’t just use the system reverb?[/quote:3bedymtv]
It is a sequencer-like application that allows the user to dynamically add sets of samples to six channels. On top of that the user is able to set different effects (with different values) for every channel. Right now I have highpass, lowpass and flange working, but it would be really cool if I could add the reverb as well. The goal of the application is to show how setting effects to separate instruments can affect the entire sound of a piece of music. Conclusion: it’s important for me to be able to set the reverb per channel. 😉

[quote="peter":3bedymtv]FMOD_REVERB_CHANNELPROPERTIES controls how much of the channel signal to send to the system reverb.

If you want to set different reverbs per channel you can create a SFX reverb DSP and use setParameter to manually set the properties.[/quote:3bedymtv]
Okay, so it sounds like I should just create a DSP per channel. Unfortunately I can’t test your suggestion at the moment, but there is one problem I am foreseeing about the implementation: using the DSP way is actually what I started this post off with. The problem then was that I couldn’t hear the reverb effect and you noted that it is required to set other properties in order for it to work. So right now I am wondering which steps I am required to take to actually activate the reverb. You said in your first reply:

[quote="peter":3bedymtv]You need to set reverb properties other than ‘roomsize’ to make it work. For a starting point take a look at the reverb presets[/quote:3bedymtv]
But if the default reverb presets can not be used for the channel reverb, then which properties do I actually need to set?

A basic code example would be really helpful.

Thanks again for your time, it is much appreciated!!!

  • Abel.
  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.