0
0

Hello,

I have just started using your wonderful program on a student project, and I’m working on a 12 channel wave file, where each stereo pair is a seperate mix of a loop with more and more instruments added for intensity.

Here’s a screenshot for a better explanation of what I’m doing:

[url:rly2k4f2]http://digitalvictim.net/images/MultichannelMusic.png[/url:rly2k4f2]

I have an event with a single layer and a channel mix, crossfading between the 12 channels over a parameter. It all works perfectly fine in Designer, but when I build my project and bring it into sandbox, the program crashes when I double click the Multichannel wave in the Media box to create an emitter.

I have tried this on both PC and Mac. I have created new events from scratch and rebuilt the project a dozen times, but it seems anything above 6 channels will not play correctly in sandbox. It will either garble the sound, crash the program, or both. On the Mac it actually crashes CoreAudio and makes everything sound static until I restart the computer.

One time however, on the PC, I did get a message that stated something along the lines of "The number of input channels exceeds the maximum amount as declared by… etc. It said this can be increased by going to system::_________ something I can’t remember.

Anyway, on the Mac, there’s no error at all, just a crash, and the Mac is my main platform. I was wondering if this was a known issue and if there was anything I could do about it. I tried the search but didn’t turn up anything. Thanks!

  • You must to post comments
0
0

Hi JPellizzi,

It shouldn’t crash in that situation, my testing here is giving me the following error:

"The sound created exceeds the allowable input channel count. This can be increased using the maxinputchannels parameter in System::setSoftwareFormat."

Currently FMOD Sandbox defaults to a maximum of 8 channels. We could make this maximum configurable in the settings menu, if that would meet your needs, we can discuss it internally and add it to our tracker.

  • You must to post comments
0
0

That would be great! I’m assuming that it is also what is causing the crash, since I’m creating a fresh project and event on my PC and Mac with the same exact result. I did manage to get that error message twice though, so it would probably fix the issue. Is there anything I can do for now to make it work? Having it as a setting would be pretty useful as well. Thanks for the response!

  • You must to post comments
0
0

I would suggest that you try using FMOD EventPlayer which should be able to handle this. I have added it to our tracker as a feature request.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.