0
0

Hi there,

i didnt find any good answer on the net, so i hope i can find some help here.
I’ve included the fmod.h in my usr/include and the libfmod.so in my usr/lib but i always get this message when im tryin to compile (with gcc):

[quote:3gcopjlv]/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../../lib/libfmod.so when searching for -lfmod
/usr/bin/ld: skipping incompatible /usr/lib/../lib/libfmod.so when searching for -lfmod
/usr/bin/ld: skipping incompatible /usr/lib/gcc/x86_64-linux-gnu/4.4.1/../../../libfmod.so when searching for -lfmod
/usr/bin/ld: skipping incompatible /usr/lib64/libfmod.so when searching for -lfmod
/usr/bin/ld: skipping incompatible /usr/local/lib/libfmod.so when searching for -lfmod
/usr/bin/ld: skipping incompatible /usr/lib/libfmod.so when searching for -lfmod
/usr/bin/ld: cannot find -lfmod
collect2: ld returned 1 exit status
[/quote:3gcopjlv]

Anyone knows what i did wrong?
Im workin on the last ubuntu version (32 bits).

Thank you.

Nicolas

  • You must to post comments
0
0

looks like your system is not that 32bit as you think it is 😉
"x86_64-linux-gnu"

is it possible that your system is biarch? If you want to build a 32bit app in a biarch system you have to set "-m32" to your compiler options, otherwise it will try to link against a 64bit lib while fmod is 32bit and fails with your error message.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.