0
0

Hi there,

I have a question regarding the 3D custom rolloff and the ‘just fail if quietest’ behavior.

I have an event with the following setup:
‘max playbacks’ = 1
‘Max playbacks behavior’ = ‘just fail if quietest’

My test scene has 3 active CEvent objects that are just wrappers over the FMOD::Event. These objects check every frame if the distance to the listener is smaller than the event’s max distance. If so, they try to reacquire the event instance (by getting the Info only event and setting the 3d position and orientation, like recommended in the docs).

This works just fine if the 3D rolloff is set to linear. Event instances are correctly stolen when the listener moves from one CEvent object to the other.
But when we changed the 3D rolloff to a custom one, no event instance was stolen anymore. The playing event remains in that state and no instance is stolen.

I also tried this in the sandbox, with the example project. To reproduce this, just change the ‘examples/FeatureDemonstration/3D Events/Occlusion’ event ‘Max playbacks behavior’ to ‘just fail if quietest’, load it in the sandbox and place two sound emitters. When moving around both emitters nothing happens, the one that is playing remains in that state. The second is in waiting state. This differs from what other 3D emitters do (‘examples/FeatureDemonstration/3D Events/3DSoundEmit’ for instance). Instances are clearly stolen when ‘flying around’.

It seems as if only one event is getting the 3d distance applied when the 3D rolloff is set to ‘custom’.

Of course, we can just go back to the linear rolloff, but I just wanted to know if this kind of behavior is expected or there is something that I’m missing.

Thanks in advance.

Cheers.

  • You must to post comments
0
0

Apologies for not addressing this earlier, to be totally honest this had fallen off my radar. I have just fixed it for you and the fix will be available in the next release which should be available in the next couple of weeks. Just to clarify: the issue here is specifically with using the occlusion effect for attenuation, if you use a volume curve over a distance parameter for the custom rolloff then that has always worked.

  • You must to post comments
0
0

Hi,

When is it going to be fixed ? We are using version 4.32.4 and the issue is still there. Go back to linear rolloff is OK for now, but definitely a quality loss.

Thanks in advance.

Chris…

  • You must to post comments
0
0

Hi Janko,

Thanks for the report. I have reproduced the issue here, we’ll let you know when it is fixed.

-Pete

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.