0
0

Hi,

I’m investigating a problem where the game is not accessing the FEV file generated by Fmod Designer 4.31.04 with a compatibility error. It works if I build the FEV files with an older version of designer (eg: 4.30.03).

In the revision_tool file, I see that the FEV file format was updated back in 4.31.00pre07 22/1/2010. The notes are:

  • .FEV file format updated! FMOD Designer 4.31.00 pre 7 requires FMOD version
    4.31.00 pre 7, 4.29.07, 4.28.07, 4.26.17, 4.24.30 , 4.22.39 or higher

Is there no Stable 4.30.x API that supports designer 2010??

Matt.

  • You must to post comments
0
0

Hi matt,

4.29 was what we called stable 4.30 when it was a dev branch. Our version number system works like this:

All even numbered branches are ‘stable’
The dev branch is always odd
When a dev branch goes stable increases up by .01 (making it even)
The revision version (the last number) gets reset when it goes stable.

So 4.29.07 is in the 4.30 branch before 4.30.00 so you should be fine using anything from the 4.30 branch. To be safe you should use an API version as new or newer than Designer, so for Designer 4.31.04 you would use 4.30.04+ API or 4.31.04+ API.

-Pete

  • You must to post comments
0
0

Interesting. We were definitely getting the FEV version unsupported error.

Just found this in the API notes (revision_stable.txt):

1/07/10 4.30.05 – Stable branch update

<snip>
* .FEV file format updated! FMOD Designer 4.31.04 requires FMOD version
4.31.04, 4.30.05, 4.28.15, 4.26.25, 4.24.38 or higher

Our tools/engine are still on 4.30.03. I’ll look at when we can update to 4.30.05 so we can use the latest designer.

Thanks.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.