0
0

Hello, I hope someone will be able to help me.
I always thought that midi playback on the iPhone with fmod wasn’t very precise so I was excited to read in the release notes for 4.32.01 that midi playback timing accuracy had been fixed. After some testing (on both device and simulator) and going back to 4.32.00 (groan) it seems to me that it’s has actually got worse.
Is there perhaps a parameter to be set to achieve increased timing accuracy?
(i use the provided sample code, the QuickTime dls sound bank and Logic generated midi files)

Or has anyone else had timing problems?
thanks

  • You must to post comments
0
0

Hi,
I’ve had the same issue, and with the latest release not only is the timing more off, but the playback speed is wrong as well (probably related).
In my tests for example a midi file set at 120bpm plays at around 125bpm, but maybe that’s not critical for your application.

I’ve submitted a detailed report to the developers so hopefully it will be fixed soon.

In the meantime I’ve found that older builds (back to 4.24 and 4.26) actually perform better as far as timing accuracy although they draw more cpu (my iPod 1st gen goes up to 90% with 4.26).

  • You must to post comments
0
0

Thanks, I hadn’t noticed the difference in tempo – I will check what happens with my midi files.
I checked mp3 playback and it works perfectly but my app has a very large number of musical excerpts in it and I need to use midi to contain the size of the app bundle itself.

Thanks for the advice, I’ll try the older builds.

  • You must to post comments
0
0

I did some testing and 4.32.01 seems indeed to be playing my midi tracks at faster speeds than indicated within the file.
That makes sense with the music sounding like it’s skipping beats.

As far as the older builds are concerned I didn’t really notice any improvement in timing accuracy.
Sticking with 4.32.00 for now.

I’m still wondering if I’m doing something wrong.
Maybe fmod doesn’t support Logic’s ppq? (couldn’t find anything in the documentation regarding this)
I can’t seem to change the ppq settings in Logic so I can’t try.
Any help from the developers?

  • You must to post comments
0
0

With the latest 4.32.02 I’m experiencing the same playback speed problems as the previous build.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.