0
0

I’m experiencing strange problem with FMOD. It seems it won’t output signal to rear speakers. I didn’t experience this with integrated Realtek card, but on SB Audigy 2 and current X-Fi Surround 5.1 cards, even with forced 5POINT1 mode, I can hear only front speakers, when listener should hear the rear ones, I got nothing.

Thanks for ideas what can it be,
Richard.

  • You must to post comments
0
0

Hi Richard,

What version of FMOD are you using? It sounds like it could be a hardware issue, you can disable hardware sounds using: [code:2suifmu8]system->setHardwareChannels(0, 0, 0, 0);[/code:2suifmu8]

  • You must to post comments
0
0

I’m using version num. 0.4.32.1. Strange is it happens only on cards from Creative, and I’m using latest drivers. Setting zero hardware channels like you said didn’t help either.

EDIT: OpenAL and other APIs can output to rear speakers perfectly, so it must be some incompatibility with FMOD I guess.

Thanks anyway,
Richard

  • You must to post comments
0
0

depends where you called setHardwareChannels, you’re supposed to call it before init, not after, just in case you were doing that.

The point of that call was to make fmod use FMOD_SOFTWARE for all sounds rather than the default which is FMOD_HARDWARE (this is no longer the case in 4.33 onwards).

A hardware 2d sound has no way to pan to the rear speakers on directsound, so things like Channel::setSpeakerMix (which is what I assume you’re using to try and get sound in the rear?) do not work with directsound buffers (they are not capable of it).
3d sounds would work just by positioning the sound behind you , this is for hardware and software sounds.

This is not a compatibility issue with FMOD, just how you’re using it.

  • You must to post comments
0
0

btw check the recommended start sequence in the FAQ section of the forum. This is the best way to get reliable output if you’re using surround sound. (and make sure all sounds are created with FMOD_SOFTWARE)

  • You must to post comments
0
0

Of course I’ve called it correctly. Thing is nothing helps, like I’m saying, on Realtek card, the same code, works with surround correctly, and with Creative cards, it won’t. I’m also using the recommended startup sequence, too, of course, that’s setting 5.1 mode as it should be, but it won’t output anything to rear speakers.

[b:1u2t6okf]EDIT: Now I’ve installed W7 on same computer, and here, the problem doesn’t exist. So it must be some kind of incompatibility only with XP and Creative Drivers->FMOD.[/b:1u2t6okf]

  • You must to post comments
0
0

This sounds like a configuration issue with your Creative "Audio Control Panel" settings. For instance perhaps you have you Windows control panel set up as 5.1 (this is what FMOD reads), but your Creative control panel set up as something else (maybe headphones). This would cause the result you are hearing.

  • You must to post comments
0
0

This is related to:
http://52.88.2.202/forum/viewtopic.php?t=13523

The issue has been resolved (pending our next release), thanks for your patience.

  • You must to post comments
Showing 7 results
Your Answer

Please first to submit.