0
0

hey, i’m really new to Fmod, and trying my hands on it for the first time
i’ve made a basic framework for an Fmod program in C#, and it’s really ugly, but it should work,
my problem however is linking C# to fmod
i’ve used the included C# linking classes
that is fmod.cs
fmod_dsp.cs
fmod_errors.cs
fmod_memoryinfo.cs

however
when i try to run the program i’ve written, a line in fmod.cs gives the error that fmodex.dll is inaccessibly
this is correct because i haven’t referenced it

however
if i try to reference it i get the following error:
"a reference to file address could not be added. please make sure the file is accessible, and that it’s a valid assembly or COM component

i have installed fmod 2 days ago, and tried referencing just after restart, while making sure there were no fmod-related programs running, it’s just not working

i’ve also tried registering the .dll with regsvr32.exe, that resulted in the following error:
"the module ‘fmodex.dll’ was loaded but the entry-point DllRegisterServer was not found \n\n make sure that ‘fmodex.dll’ is a valid DLL or OCX file and then try again"

i’m at a complete loss for what to do at the moment, and i don’t know if this was posted before because it’s impossible to search for [c#] on this forum, because it doesn’t take the string "[c#]" or even "c#" into account when searching

thanks in advance for any help or advice you are able to provide

  • You must to post comments
0
0

You don’t need to ‘reference’ it or use regsvr32 at all, just make sure the .cs files are included in your project and the .dll is in the same folder as the .exe for your program (if you are using visual studio, this should be something along the lines of:- My Documents\Visual Studio 2008\Projects\project\project\bin\x86\Debug) and it should work fine.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.