0
0

I think there’s a bug in the EAX support of fmod.

Go to the Creative EAX Control Panel in the Creative AudioHQ, and setup some reverb effect (for example set reverb to 30%).
When you now initialize fmod, the reverb setting is set to 0% (or -infinity on the latest liveware) and you cannot change the reverb setting anymore in the EAX Control Panel. Whatever reverb setting you try, it isn’t audible in the sound. When fmod is closed, you can set the reverb back.

I use the following initilization:
FSOUND_Init(44100, 32, FSOUND_INIT_GLOBALFOCUS);
I get the same effect when i use the sample fmod.exe program.

Is there a way to solve this problem?

btw: I really like the FMod library. Keep up the good work.

  • You must to post comments
0
0

Nobody can help me 😥

  • You must to post comments
0
0

Ok, but isn’t it possible to include an option, so we can choose if Fmod should initialize and reset eax?
I’m currently using Fmod in a windows program (not a game) and it really isn’t that nice that each time my program starts, all the user eax settings are reset :(

edit:
The problem is, once Fmod has reset eax, you can no longer change the eax settings in the control panel as long as the program is running. For games this is not a big issue, but for a program it is.

  • You must to post comments
0
0

Isn’t it possible to include a fsound_restore_eax_settings?

The weird thing is, when fmod is loaded, the creative eax control panel reverb setting does not work at all.

  • You must to post comments
Showing 3 results
Your Answer

Please first to submit.