0
0

Hey, still pretty new to FMOD, and having a problem with sharing a FMOD sound library. When building the project, it gathers data from the sound files using their absolute paths ( c:\mysound\subdir\aaa.wav ). Obsiously, when moving the library to another computer, the paths aren’t found.

To fix this, I want to use local paths. So:
– Libraries are placed in the root folder where all the sound files are. Example:
[code:1iqy31f7]
c:\mysound\ <– libraries are here
c:\mysound\subdir\aaa.wav local path = "subdir\aaa.wav"
[/code:1iqy31f7]
– In Events, "Audio Source Directory" is set to "", empty
– When adding a soundfile, I can see it removed the root part

When I move the entire folder & libraries to another disk location, I can still play the sounds in Designer. But when building the project, it still refers to the old absolute locations. I get the "couldn’t read from file" error.

Any way to solve this? I’d like to let multiple people work or at least review the libraries, and I can’t expect all of them having the exact same rootfolder or disk drive letters.

Rick

  • You must to post comments
0
0

You can make your paths all relative to the project directory by setting the path as ‘.’ (without the quotation marks). That will prevent designer using absolute paths.

  • You must to post comments
0
0

You’ve gotten a whole lot of people asking this lately. Maybe make this the default when creating a new project? Or, make the behavior equivalent if the path is blank?

  • You must to post comments
0
0

It is relative by default, however when you ‘Save as’ it will force the paths to absolute, which is what I think might have happened here.

  • You must to post comments
0
0

Thanks, that worked! I filled the source path as an empty string instead of a dot, that’s why it didn’t work.

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.