0
0

I’m very new to FMOD, but after searching I didn’t find an answer to this question so I’m posting it.

I’m running on a Win32 system, using FMOD 3.6.

When I compile and run the sample 3D app, sound #1 (drumloop) gets louder and quieter as the listener position moves L-to-R, but it doesn’t pan from the left speaker to the right speaker and back as I would expect. I’ve tried the sample app on two different machines, one with a video card that supports 3D hardware channels and one that does not. Results are the same.

In the course of trying to figure out the problem, I’ve modified the app a bit so that I can manually move the sound about–front to back, left to right–as well as adjust the listener’s orientation (simulating turning the head from left to right), all with no luck. The sound gets quieter as it moves farther away, but does so in mono. Panning manually likewise has no effect.

As full-featured as FMOD appears, I find it very hard to believe that it can’t do this. I mean, what good is 3D sound if it only gets louder or quieter? That’s 2D sound along the wrong axis! The error must be on my side. I would greatly appreciate any help!! :)

I’ve got another question about the FSOUND_3D_Listener_SetAttributes parameters which may or may not be related to these problems, but I’ll post it in a separate topic.

  • You must to post comments
0
0

I wasn’t trying to say there was a bug–I tried to be clear that I realized the problem must be something on my end.

And, sure enough, it was a problem with the way my speakers are hooked up! I’ve got a somewhat complex setup, but it hasn’t been this way long and I hadn’t noticed yet that it was forcing everything mono!

I noticed the jungle sound 2d issue as well, but that was the least of my worries. 😆

Everything seems fine now. Thought I’d pass that on.

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.