0
0

Hi,

I am trying to get C++0x working into my program. That’s why I am trying to enable flag "-std=C++0x" when compiling with mingw (4.4 or 4.5) downloaded from tdm. I’ve just
downloaded the latest 32bits stableversion for windows.

Here is the output from compiler:
[code:3146ckfe]
In file included from D:\libsC++\fmodex/fmodex/fmod.hpp:11:0,
from D:\projets\bc0.2\src\audio/CSound.hpp:8,
from D:\projets\bc0.2\src\CSpeaker.cpp:2:
D:\libsC++\fmodex/fmodex/fmod.h:1041:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1043:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1045:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1046:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1047:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1049:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1050:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1051:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1052:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1053:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1054:33: error: expected ‘)’ before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1056:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1056:33: error: expected initializer before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1057:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1057:33: error: expected initializer before ‘‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1058:33: error: expected ‘)’ before ‘
‘ token
D:\libsC++\fmodex/fmodex/fmod.h:1060:33: error: expected ‘)’ before ‘*’ token
[/code:3146ckfe]
Any idea how to solve this ? is it normal ?

Thx

  • You must to post comments
0
0

It doesn’t change a thing (I just tried to include fmod.h instead of .hpp), I don’t use C++ interface and my program has been running & compiling just fine for a year or so. Just this week I decided to switch the flag -std=C++0x and it doesn’t work. It might be a gcc implementation problem since C++0x support is still in test. I wonder if there is the same problem with Visual C++ and c++0x support enabled ?

  • You must to post comments
0
0

You need to use the FMOD C API when compiling with mingw.
Take a look at the note regarding supported compilers in the getting started guide for more details.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.