Mac OSX 10.6.4 – FMOD Designer 4.32.07 – FMOD Sandbox 4.32.07


I’ve spent a while making a bunch of 3d emitters in Designer which i’m really happy with. I can build the project fine, and load the .fev file into a sandbox projects. From there I can drop the emitters into the space and move around… everything working well so far, and the results are very pleasing.

However, when I save my sandbox project, and close the sandbox, i cannot return to the project at a later date. This is because the Sandbox is not saving the project with a .fsp extension, which is the type sandbox reads. So when i go to File->Open-> and navigate to my saved project file, it is greyed out hence not available for selection. Alternatively, navigating to the project file first, and choosing ‘Open With’ doesn’t work either; FMOD Sandbox is greyed out.

The only thing i can open the saved file with is a text editor. When i do this, i see all the emitter information as it should be (coordinates of moving paths, etc).

I have found a work-around here, by opening the sandbox, loading the correct .fev file, then selecting File->Recent Projects. This opens the project with all the emitters in the places i left them, and i continue working on my file. Problem is, this is a uni submission, so when a marker accesses my files on a different machine, the ‘Recent Projects’ list will not contain my project. And they won’t be able to open my project file, as it is not a .fsp. Also worth noting, opening in this method causes a sandbox crash 4/5 times.

I’ve tried manually adding the .fsp extension to the saved file myself, but no luck. I’ve tried re-installing sandbox, and also tried it on a different machine (same operating system). I’ve tried using the developer version of the sandbox too (4.33.07) – but the same thing happens every time. Everything else works fine, the .fev files load correctly, and I can create a virtual space full of my emitters. But I can’t seem to save a project in a format which can be opened again!

Does anyone have any suggestions here? Does it sound like i’m doing something wrong?



  • You must to post comments

When you save your file with Sandbox, you can simply include the extension in the name, i.e. go file -> save as -> blah.fsp this will save with the desired extension and be openable. If you do not specify an extension it will save without one (I will fix this for our next release to always add .fsp if it’s missing). For existing files saved without an extension you can simply add the required fsp extension from the finder, I can confirm this does work (perhaps the file you had saved became corrupt, hence why this didn’t work for you).

  • You must to post comments
Showing 1 result
Your Answer

Please first to submit.