0
0

Hello,

I’m trying to get FMOD working with OSS version 4 build 1016 from http://www.opensound.com. I’m using CentOS 5.3 with an Nvidia nForce2 AC97 sound codec and FMOD version 4.32.02.

Other OSS applications play sound correctly, but when I try using FMOD I get the following error:
“osscore: Output timed out on audio engine 2/’Nvidia nForce2 (VMIX0)’ (count=0)”

This error repeats indefinitely on the terminal until the application exits.

cross posted on the OSS support site: http://www.opensound.com/forum/viewtopi … 185872fc7a

  • You must to post comments
0
0

I’ve gotten this issue fixed with some feedback from the FMOD support team.

They suggested changing FMOD’s buffer size from the default of 1024 samples using System::setDSPBufferSize. Here’s the comment from the help page on that function:
[quote:26ul01af]Sets the FMOD internal mixing buffer size. This function is used if you need to control mixer latency or granularity. Smaller buffersizes lead to smaller latency, but can lead to stuttering/skipping/instable sound on slower machines or soundcards with bad drivers.[/quote:26ul01af]

I doubled it to 2048 samples, and the sound started working and the "Output timed out" OSS error message went away.

  • You must to post comments
0
0

Still haven’t gotten this fixed.

I’ve updated both OSS and FMOD Ex to the latest versions, but neither had any effect on the issue.

I compiled the FMOD playsound example application, and I’ve configured it to explicitly use OSS.

I tested my application on a separate nForce4 motherboard, also configured to use OSSv4 but with a different oss_hdaudio.ko kernel module – the nForce2 board uses the oss_ich.ko module. Everything worked correctly on this machine.

Back on the nForce2 machine, I changed the "vmix0-channels" setting from "Stereo" to "Multich". With this the playsound application started giving me sound, but very garbled – like the speakers were behind an oscilitating fan. I tried a separate pair of headphones plugged directly into the motherboard to verify that it wasn’t the speakers themselves.

  • You must to post comments
Showing 2 results
Your Answer

Please first to submit.