0
0

For you users: What is the best way any of you have found to set up an FMOD event which repeatedly plays the same sound-def, rapidly and with reliably regular timing? I’d like to set up a machine gun (about 600 rpm) by repeatedly calling a single shot sound. The methods I’ve tried so far haven’t really worked because the timing comes out irregular.

  • You must to post comments
0
0

… so I think the "guilty" could be the CryEngine

CryEngine seems to use an audio system that is frame rate dependent while other games like Battlefield use an frame rate independent system, meaning that is capable of playing sounds between frames.

With frame rate dependent system: "If you try to play a high rpm weapon with a frame rate dependent audio engine it plays back un evenly. For example if the frame rate is 30 Hz and the rpm of the gun is 25 the audio engine will try to play a sound every 1.2 frames. This is can’t do so what you’ll get is something like 4 frames where a sound will play then it will skip a frame and then start playing again for 4 frames etc."

  • You must to post comments
0
0

… I posted this issue on crydev (I’m looking for the guilty lol)

http://www.crydev.net/viewtopic.php?f=322&t=118698

  • You must to post comments
0
0

try a spawning sound definition, then in the sound instsance properties, choose ‘wait for previous’ as the play mode, then it should give you sample accurate stitching.

Have you tried a simple event? It has granular sample support and does all this stuff for you.

  • You must to post comments
0
0

Thanks to reply Brett, I hear your advices with attention… I Tried "wait for previous" but it doesn’t solve the problem… (I don’t use granular)

Here is what I do:

A weapon sound for a realistic game (CE engine)…
I have two sound definitions and for each 5 .wav (24/96 for now)
I ‘ve set a basic one shot even that contain two layers (mode immediate)
The weapon have a burst mode (3 shots at time) and the engine is responsible to respawn the event 3 times at the correct rate (here 750 rpm). for that reason I don’t use granular(should I ?)…
If it’s the engine that is responsible of this issue, I should must find another way to get the sound properly…

  • You must to post comments
0
0

…Hello,

The same problem here, don’t know why it become irregular to about 700 rpm setting, I’ve tried to play with dsp buffer size and it seems to be better but not enough to be realist…

Someone have solved this problem ?

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.