This is not really a bug, but I think it should work
in another way…

From the docs:

Sets the master volume for any sound effects played.

So I thought of it like a mixing device, where there
is a Master Volume and independent Volume knobs for
the rest of the channels… And it almost work like
that, except for a little detail: there must be at
least one sound playing for it to work, so you can’t
set the Master Volume before playing anything, but
after it. And if there’s sth playing, you set the
Master Volume, and you stop all channels playing, when
you play sth again you’ve lost the last Master Volume.

I suppose that when calling FSOUND_SetSFXMasterVolume,
you go through the array of playing sounds and set the
appropiated output volume, but when there are no
playing sounds you just do nothing.

It should be easily fixed by declaring an internal
variable that, in case there’s no sound playing,
should save the Master Volume the user passes to
FSOUND_SetSFXMasterVolume, and so when you started
playing anything you could use it to set the correct
output volume.

Oh, and I know you perfectly know how to fix this
kinda things, but I’m also a programmer and can’t
resist explaining these things… hope I’ve got your

Thanks 😉 !

  • You must to post comments

In our current project, we have implemented our own master/individual volume settings primarily because we want different volume levels for sfx, music and voice-overs.

  • You must to post comments

That’s good, but… do you know if FSOUND_SetSFXMasterVolume LOSE its setting when there are no channels playing, or is it a problem of mine?

  • You must to post comments

Grrllll 👿 … I’m starting to H A T E Creative… Don’t they realize they’re receving a lot of reports from users with problems with their drivers, and that they should release patched drivers ASAP??? FYI, Guillemot Fortissimo II is coming out soon, and will support EAX2 without bugs (or at least they’ll fix it), so I’m gonna buy that card and sell my SB Live! as soon as I can…

  • You must to post comments

We explicitly set the volume after each call to play a sound. We are using Win2K as our development platform. So I guess we might have unknowingly implemented a work-around for the Creative bug. Damn…

  • You must to post comments

As Sly already said, its easy. just add a FSOUND_SetSFXMasterVolume(somevalue) [b:2ig32iz2]exactly[/b:2ig32iz2] after calling FSOUND_Stream_Play …
The same goes for individual channel volumes. Add a FSOUND_SetVolume(channel,value) right after FSOUND_Stream_Play and volumes work right.

It works for me, it should work for u too :roll:


<font size=-1>[ This Message was edited by: Abishai on 2001-07-02 10:31 ]</font>

  • You must to post comments
Showing 5 results
Your Answer

Please first to submit.