0
0

I’d like to see two options for midi files:

  • that setting FMUSIC_MasterVolume would set the volume the midi is played,
  • and that DSP info and such is being given for playing midi’s.

Could that be implemented?

  • You must to post comments
0
0

Ok pity about the DSP thing but…
I have been trying to use FMUSIC_MasterVolume for 5 different midi files, tried it on all available devices on my computer, but none have any effect: FMUSIC_SetMasterVolume doesn’t work with me for midi’s. The same code works when I load a module type of file though.

Any thoughts?

  • You must to post comments
0
0

I came to the forum to ask the exact same question. For what it’s worth, FMUSIC_SetMasterVolume makes absolutely no difference in volume when I use it. I have verified the call is returning True, and if I call FMUSIC_GetMasterVolume I am seeing the value I set it to. Even if I set it to 0 it still sounds the same. This is a bit of a problem in game since the midi sound is overpowering everything else. 😕

  • You must to post comments
0
0

Ok. I tried the dll you posted with the same results. If I use FSOUND_INIT_USEDEFAULTMIDISYNTH I don’t hear the midi at all… Go figure.

  • You must to post comments
0
0

Hi!
I’ve got the same problem.
The flag FSOUND_INIT_USEDEFAULTMIDISYNTH turns the software-decoding on. (help-file: 0x01 /* Causes MIDI playback to force software decoding. */ )
Then all works fine here, the volume can be changed with FMUSIC_SetMasterVolume().

But if I want to use hardware-MIDI-playback, and leave out the flag, I hear the MIDI-Song and can change the Music-volume-value, but without any hearable effect.

hmmmmmm.
Perhaps it is really a bug?

  • You must to post comments
Showing 4 results
Your Answer

Please first to submit.